A Sysadmin's Unixersal Translator (ROSETTA STONE)
from http://bhami.com/rosetta.html

Categories:

hardware, firmware, devices disks kernel, boot, swap files, volumes
networking security, backup software, patching, tracing, logging references
TASK \ OS  Linux
Solaris
OS notes (rh) = Red Hat,
Mandrake, Suse,...
(deb) = Debian, Libranet,...
(mand) = Mandrake
(SuSE) = SuSE
Solaris 2.0-2.6, 7, 8, 9
(SunOS 5.*)
SVR4-based
administrative GUI (rh) redhat-config*
linuxconf (obsolete)
(SuSE) yast2
(deb)
dpkg-reconfigure
(mand)
drakconf

solstice
admintool
smc (8 01/01+)

managing users

useradd
userdel
adduser

useradd
userdel
usermod
/usr/sadm/bin/smuser (9+)
TASK \ OS  Linux
Solaris
list hardware configuration

dmesg (if you're lucky)
/proc/*
lspci
(SuSE) hwinfo

prtconf -v
/usr/platform/`uname -i`/sbin/prtdiag

arch -k
psrinfo -v
isainfo -v
dmesg
iostat -En
prtfru
cfgadm -l
/etc/path_to_inst

show/set
EEPROM/NVRAM
values
/dev/nvram (if you have it)
hwclock
nvsetenv
eeprom
add device without reboot modprobe
kerneld
insmod
hotplug
cardctl
devfsadm. pre-Solaris 7 HW 11/99, use:
drvconfig; devlinks; {disks, tapes, ports}
tape device /dev/st0 /dev/rmt/0
X kvm config xf86config
XFree86 -configure
redhat-config-xfree86
/etc/X11/?dm
kdmconfig (x86)
fbconfig; m64config; (etc.)
TASK \ OS  Linux
Solaris
read a disk label  fdisk -l prtvtoc
whole disk in partition  ? 2
label a disk  cfdisk
fdisk
e2label
format
prtvtoc
partition a disk  parted (if you have it)
fdisk
pdisk (on a MAC)
format
fmthard
TASK \ OS  Linux
Solaris
kernel

/boot/vmlinuz*
/boot/bootlx

(see /etc/lilo.conf or /boot/grub/menu.lst)

/kernel/genunix
/platform/`uname -m`/
 kernel/unix
/platform/`uname -m`/
 kernel/sparcv9/unix (7+)
show/set kernel parameters /proc/*
/proc/sys/*
sysctl
/etc/sysctl.conf

sysdef
getconf
cat /etc/system
ndd
adb -k

make disk bootable

(rh) mkbootdisk
(deb) fdisk -A
(and lilo to manipulate mbr)

installboot /usr/platform/
`uname -m`
/lib/fs/ufs/bootblk raw_device_file
startup scripts  /etc/rc* (but may vary)
/etc/init.d/
/etc/rc*
/etc/init.d/
run levels 1
*=normal states
for more detail
see

www.phildev.net/runlevels.html
(set in /etc/inittab)
0: halt
s,S,1: vendor-dependent
1: single-user
2-5*: multiuser
6: reboot

0: firmware monitor
s,S: single-user
1: sys admin
2: multiuser
3*: share NFS
4*: user-defined
5: power-down if possible
6: reboot

show runlevel 1 /sbin/runlevel who -r
time zone info /usr/share/zoneinfo/ /usr/share/lib/zoneinfo/
check swap space  swapon -s
cat /proc/meminfo
free
swap -s
swap -l
TASK \ OS  Linux
Solaris
"normal" filesystem  ext2
ext3
ReiserFS
ufs
volume-based filesystem  LVM, LVM2
EVMS
VxVM ($)
Solstice DiskSuite
VxVM ($)
file system
description
 /etc/fstab /etc/vfstab (local)
volume manipulation e2fsadm
lvcreate
lvremove
lvextend

meta*
(Solstice DiskSuite;
Solaris Volume Mgr (9+))
(7-, found in
/usr/opt/SUNWmd/
 sbin/)

/opt/VRTSvxva/bin/vxva
(Veritas Volume Mgr) ($)

create filesystem mke2fs
mkreiserfs
mkdosfs
newfs
mkfs
create non-0-length empty file dd if=/dev/zero of=filename
bs=1024k count=desired
mkfile
mount CDROM mount /mnt/cdrom
(deb) mount /cdrom
/etc/init.d/vold start; volcheck or
mount -F hsfs -o ro /dev/dsk/c0t6d0s2 /cdrom
TASK \ OS  Linux
Solaris
NFS share definitions /etc/exports /etc/dfs/dfstab
dfshares
NFS share command /etc/init.d/nfs-server reload
(rh)
exportfs -a
share
shareall
name resolution order /etc/nsswitch.conf
/etc/resolv.conf
/etc/nsswitch.conf
getent
show network interface info /sbin/ifconfig ndd
ifconfig -a
netstat -in
(8+) kstat -n hme0 | egrep 'ifspeed|duplex'
change IP

(rh) edit: /etc/hosts,
/etc/sysconfig/network,
/etc/sysconfig/
network-scripts/
ifcfg-eth0
(deb) edit
/etc/network/interfaces;
/etc/init.d/networking
restart

edit: /etc/{resolv.conf, hosts, hostname.*, netmasks, nodename,
dumpadm.conf, net/*/hosts}

sys-unconfig; reboot

ping one packet   ping -c 1 hostname ping hostname  packetsize 1
sniff network etherfind
tcpdump
ethereal
etherape
snoop
route definitions  route
(rh)
/etc/sysconfig/network
(rh) /etc/sysconfig/static-routes
(deb) /etc/init.d/network
(deb) /etc/network

/etc/defaultrouter
/etc/notrouter
/etc/gateways

in.routed

netstat -r

telnetd, ftpd banner /etc/issue.net (telnet)
(ftp varies; can use tcp wrappers)
/etc/default/telnetd
/etc/default/ftpd
TASK \ OS  Linux
Solaris
encrypted passwords in  /etc/shadow (may vary) /etc/shadow
allow/deny root
logins
/etc/securetty /etc/default/login
firewall config ? (9+) /usr/aset/
TASK \ OS  Linux
Solaris
show installed software  (rh) rpm -a -i
(rh) rpm -qa
(deb) dselect
(deb) dpkg -l
pkginfo
prodreg
admintool
/var/sadm/install/contents
add software (rh) rpm -hiv
(deb) dselect
apt-get install pkg
(deb) dpkg -i
pkgadd
precompiled binaries of GPLware and freeware http://www.linux.org/
linux.tucows.com
sourceforge.net
rpmfind.net
http://www.sunfreeware.com/
C compiler   gcc /opt/SUNWspro/
 bin/cc ($)
show patch level
and/or patches
(rh) rpm -q
(deb) dpkg -s
showrev -p
prodreg (2.6+)
patchadd -p
patch tool  apt-get update
apt-get upgrade
(rh) up2date
(mand) urpmi
installpatch (2.5.1-)
patchadd (2.6+)
pkgadd
/usr/sadm/bin/smpatch (9+)
configure/show
runtime linking
fortran-2000.com/
ArnaudRecipes/
sharedlib.html
ldconfig
ldd
lsmod
crle
ldd
pldd
modinfo
link library path $LD_LIBRARY_PATH
/etc/ld.so.conf
$LD_LIBRARY_PATH
tracing utility 

strace
ltrace

truss
sotruss
define user defaults /etc/profile
/etc/security/
/etc/skel/
/etc/default/login
/etc/profile
/etc/security/
csh global .login /etc/csh.login /etc/.login
default syslog and messages /var/log/syslog
/var/log/messages
/usr/adm/messages
/var/log/maillog
/var/adm/messages
/var/log/syslog
system error reporting tool 

dmesg

(deb) reportbug
/usr/platform/`uname -i`/sbin/prtdiag
performance monitoring vmstat
procinfo -D

sar; iostat; kstat;
mpstat; netstat; nfsstat;
prstat; trapstat; vmstat; ptree

match process to file lsof fuser
TASK \ OS  Linux
Solaris
FAQs (see also faqs.org)

www.linuxdoc.org/
FAQ/Linux-FAQ

www.debian.org/doc/FAQ

www.faqs.org/faqs/Solaris2/FAQ/
www.faqs.org/faqs/Solaris2/x86/FAQ/
www.stokely.com/
unix.sysadm.resources/
faqs.sun.html
mailing list 

www.linux.org/
help/lists.html

sun-managers@sunmanagers.org (majordomo)
mailing list archives  lists.debian.org

www.sunmanagers.org/archives.html

www.latech.edu/sunman.html

newsgroup(s)
groups.google
comp.os.linux.* (esp .answers) comp.sys.sun.
admin
, comp.unix.solaris 
user groups http://www.debianhelp.org/ ?
magazines http://www.linuxjournal.com/
http://www.linux-mag.com/
http://www.debianplanet.org/
http://www.sunworld.com/
sun.com/sun-on-net/itworld
vendor home page http://www.linux.org/
http://www.redhat.com/
http://www.debian.org/
sun.com/solaris
sun.com/bigadmin
sun.com/developers/support
soldc.sun.com
access1.sun.com
vendor docs and patches www.linuxdoc.org/
rpmfind.net/linux/RPM
docs.sun.com
sunsolve.sun.com
vendor phone (US) ? 800-USA-4SUN
TASK / OS Linux Solaris